SurveySparrow - EU WEST (London): Builder Service Performance Degradation – Incident details

EU WEST (London): Builder Service Performance Degradation

Resolved
Degraded performance
Started 5 days agoLasted less than a minute

Affected

EU WEST (LONDON)

Operational from 11:19 AM to 11:19 AM, Degraded performance from 11:19 AM to 11:19 AM, Operational from 11:19 AM to 11:20 AM

Builder

Operational from 11:19 AM to 11:19 AM, Degraded performance from 11:19 AM to 11:19 AM, Operational from 11:19 AM to 11:20 AM

Updates
  • Resolved
    UTC
    Resolved
    Service performance recovered at 16:50 IST. Root cause was outbound network saturation on a shared cache during elevated automated traffic. Builder validation and telemetry remained healthy after recovery. Capacity and resilience follow-up is in progress.
  • Monitoring
    UTC
    Monitoring
    Builder performance recovered after additional application capacity was added. We are monitoring service stability before resolving the incident.
  • Investigating
    UTC
    Investigating

    We are currently experiencing performance degradation in our EU WEST(London) region, affecting Builder services.Our team is currently investigating and working to resolve the issue as quickly as possible. We will provide additional updates as we progress.