SurveySparrow - Degraded Performance – Survey Email Shares & Reminders – Incident details

Degraded Performance – Survey Email Shares & Reminders

Resolved
Partial outage
Started 28 days agoLasted about 8 hours

Affected

ASIA PACIFIC (MUMBAI)

Partial outage from 5:42 AM to 1:17 PM

Notifications

Partial outage from 5:42 AM to 1:17 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are currently experiencing degraded performance affecting survey email shares and reminder deliveries.

    Users may notice delays in email distribution.

    The issue has been identified and is caused by temporary resource contention within our backend systems. Our engineering team is actively working to resolve this as a priority and restore normal performance.