SurveySparrow - Submission Updates Due to Question/Choice Changes May Experience Delays in AP DC – Incident details

Submission Updates Due to Question/Choice Changes May Experience Delays in AP DC

Resolved
Operational
Started about 1 month agoLasted about 1 hour

Affected

ASIA PACIFIC (MUMBAI)

Operational from 7:46 AM to 8:52 AM

Responses & Analytics

Operational from 7:46 AM to 8:52 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Please be aware that when updates are made to submissions, such as changes to questions or choices, it may take some additional time to process and reflect in the AP Data Center. We appreciate your patience as we work to ensure the changes are applied smoothly. Thank you for your understanding!